Live - Supplier Compliance Task Creation Delayed

Incident Report for SafetyChain

Resolved

Incident did not have any customer impact and has been resolved. We will continue to monitor for any irregularities in processing.
Posted Jun 24, 2025 - 11:18 EDT

Investigating

We are currently investigating an incident in the Live environment where Supplier Compliance task creation may be delayed for some customers.
Posted Jun 24, 2025 - 08:58 EDT
This incident affected: Tasks.