Scheduled Tasks Not Appearing in the Inbox

Incident Report for SafetyChain

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 16:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 16:03 EDT

Update

We are continuing to investigate the cause of this incident.
Posted Mar 10, 2025 - 15:57 EDT

Investigating

We are currently investigating an incident in the Live environment where scheduled tasks are not appearing in the inbox for some customers.
Posted Mar 10, 2025 - 11:41 EDT
This incident affected: Tasks.